Wednesday, August 07, 2013

PyDev: poll about minimum Java/Eclipse versions to support

Ok, one issue that has been brought up a few times in the last month was the reasons for supporting older versions of Java and Eclipse in PyDev...

Java 7 has been around for a while already (and Java 6 EOL was about a year ago), so, I'm considering making newer versions of PyDev compatible with Java 7 and dropping support for older versions. If there are use cases where people that can't upgrade, I'd like to know about those.

Also, the latest PyDev can support up to Eclipse 3.2 (although some features might not be available if they were introduced on later versions of Eclipse, the reason for this was that Aptana Studio 2 was built on that version, but it's also no longer active, so, this may be a bad reason at this time) -- note that right now the codebase needs to be compiled with the latest Eclipse version, but in runtime it can support older versions of Eclipse.

So, I'm considering supporting only Eclipse 3.8 and 4.3, but I'd also like feedback to check if there are scenarios where this can be a problem...

17 comments:

Andreas Pakulat said...

We're still supporting MacOSX back to 10.4 with our PyDev-using IDE. We may drop 10.4 and require 10.5 in the near future. Java 1.7 is not available for that platform. On other platforms we ship the JRE ourselves so thats less of a concern.

The Eclipse requirement is less of an issue to us I think. Eclipse 3.8 didn't seem to be giving us anything important so far, but as long as thats supported we could use that. 4.2 and 4.3 do not seem to give us enough incentive at the moment to base our IDE on it.

All that being said, we're fine with sticking to PyDev 2.8 for now and then reconsider the Java and Eclipse situation once we see something in PyDev we really need.

Sander Teunissen said...

No problems here with only supporting the latest versions....

Unknown said...

Please ignore Java 6. Nobody should use it on Windows since security fixes are not available any more (or only for Oracle customers).

Regarding Eclipse, supporting only the latest version can be a problem when other plugins are not yet compatible with a new version. Personally, supporting only Eclipse 4.3+ would be ok for me, though.

Dan said...

I try to keep things current as well. 3.8 and 4.3+ works for me.

dsh said...

I use Eclipse 4.3 on Java7. I approve of dropping support for Java6.

Mijo Grańćanin said...

Eclipse 4.3 and JDK7 here, I'm always up to date.

Anonymous said...

Always the current version, or one back for a few weeks till I see the current version is OK

Alexander Kurtakov said...

Java 7+ and Eclipse 4.3+ from my side :).

Anonymous said...

Eclipse 4.3 and JDK7 here, too.

Tien Bui Duc said...

I think pydev is very good but autocomplete code in Netbean support maybe better
http://tientuts.blogspot.com/2013/08/ide-for-python.html

can you support suggest type of unknow variable and store it after # like netbean.

I don't know first comment posted or error, so I re post, delete one if duplication

Fabio Zadrozny said...

Hi Tien Bui Duc,

Actually, the latest release should support that. See: http://pydev.org/manual_adv_type_hints.html for details.

Tien Bui Duc said...

thanks for your information, but can you support Epydoc in comment in main document (not in function - def)?

Epydoc support autocomplete in eclipse, I use it good in document but if a python file only:

first: import string

after:
#@type a: string
a.

or
'@type a: string'
a.

I can't autocomplete.
I can do with:

#::type a: string
a.

but @ty can ctrl+ space to autocomplete and less character.

Fabio Zadrozny said...

Please create a feature request at https://sw-brainwy.rhcloud.com/tracker/PyDev/ for that.

rgrunber said...

Eclipse 4.3+ and Java 7+ seems fine to me.

Mike Housky said...

I don't count much since I am just learning to use PyDev. As long as older versions of PyDev are available for those who must run with earlier version of Java/Eclipse/whatever, what's the problem?

PS: (Java 7 and Kepler...whatever that number is)

madhu puri said...

I am using eclipse 3.3 europa version.... i installed pydev plugin through pydev update site... But I didnt get new project wizard after selecting NEW>PROJECT>PYDEV PROJECT

Fabio Zadrozny said...

Hi Madhu,

Please report issues at https://sw-brainwy.rhcloud.com

Cheers,

Fabio