Wednesday, June 23, 2010

Preparing for Pydev 1.5.8 (testers needed)

Pydev 1.5.8 is now in polish mode for a new release, so, anyone wanting to test it, this is a good time (and it should be pretty stable already). Just grab the nightly to test it: See: http://pydev.org/download.html for instructions.

The major change is that Pydev now takes advantage of the newest features in Aptana 3 (beta).

Noteworthy features incorporated:

1. Theming: The colors in the chosen theming (Preferences > Aptana > Themes) are properly used.



2. Find Bar: Instead of the default Find/Replace dialog, a find bar is shown at the bottom of the editor for doing common searches (and the next Aptana release will also add replace actions to that bar).



Some other niceties include:

- An additional choice for the title of django editors, showing a different icon but still adding the regular name of the file to the title was added.

- Jars are now signed (some people were getting corrupt installs with problems when downloading pydev, so, this will hopefully fix that).



- A bunch of bug-fixes :)

6 comments:

Major Tal said...

Does Pydev now support Eclipse 3.6 Themes?

Fabio Zadrozny said...

What it supports is Aptana Themes (I don't think Eclipse has anything like that on 3.6).

Anonymous said...

I try to install Pydev Nightly builds over Aptana 3 last Beta:


Your original request has been modified.
"PyDev for Eclipse" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: PyDev for Eclipse 1.6.2.2010090111 (org.python.pydev.feature.feature.group 1.6.2.2010090111)
Software currently installed: Aptana Studio 3 3.0.0.201008261509-26082010151005 (com.aptana.rcp.product 3.0.0.201008261509-26082010151005)
Only one of the following can be installed at once:
Fastparser Plug-in 1.6.2.2010090111 (com.python.pydev.fastparser 1.6.2.2010090111)
Fastparser Plug-in 0.9.7.1 (com.python.pydev.fastparser 0.9.7.1)
Cannot satisfy dependency:
From: Aptana Studio 3 3.0.0.201008261509-26082010151005 (com.aptana.rcp.product 3.0.0.201008261509-26082010151005)
To: com.python.pydev.fastparser [0.9.7.1]
Cannot satisfy dependency:
From: PyDev for Eclipse 1.6.2.2010090111 (org.python.pydev.feature.feature.group 1.6.2.2010090111)
To: com.python.pydev.fastparser [1.6.2.2010090111]

Fabio Zadrozny said...

I'll take a look at that... in the meanwhile, there's a new aptana release available with the django templates editor already builtin.

See: http://aptana.com/products/studio3/releasenotes

kraeMit said...

Is it possible to use the Aptana theme in a Eclipse + Pydev installation?

Fabio Zadrozny said...

You need Aptana to have the themes.