Wednesday, December 09, 2009

Pydev 1.5.2 and 1.5.3 released

Just to note, Pydev 1.5.3 was a 1 bug fix release, fixing an annoying bug (an error would be print to the console when running on python -- although everything would still work as expected).

As for 1.5.2, the changes were focused a lot on memory and performance improvements (special thanks to the Eclipse Memory Analyzer, it really helped a lot).

Basically, Pydev had some memory peaks when analyzing modules, because it expected Eclipse to properly manage Jobs created (which are basically threads managed by Eclipse), but it turns out things were not so straightforward, so, say that you changed 500 files (in a source-format operation), it would happily go on and try to create 500 threads in the analysis (that's now fixed).

Other memory savers were targeted at handling Strings (which are 'sort of' internalized now when parsing the code, but without using PermGen space). And not keeping references to Tokens from the parsing alive (because any reference to any Token would keep all alive).

On the performance side, some changes were done to the grammar to make it a bit faster (that area had already been profiled a lot, so, there are not many performance improvement opportunities there).

Aside from that, the compare editor now has proper syntax highlighting, indentation handling and code completion from the Pydev editor. And as usual, some other minor niceties and bug fixes are available.

17 comments:

Sargis Dallakyan said...

Thank you for the post. This comment is to let you know that the link to Eclipse Memory Analyzer is missing http:// in front.

Thanks,
Sargis

siebert said...

Hi,

I can't install Pydev 1.5.3 on Eclipse 3.4.2 (tried on both windows and linux), the first error is:

Unsatisfied dependency: [org.python.pydev 1.5.3.1260390783] requiredCapability: osgi.bundle/org.eclipse.compare.core/0.0.0

Fabio Zadrozny said...

I'll take a look at that (I didn't realize that the compare feature wasn't available on Eclipse 3.4 -- should probably be an optional dependency then)

Fred said...

I have a problem... I get new installation of eclipse, and I try to install via update, the follow errors ocurrs:

Cannot complete the request. See the details.
Cannot find a solution satisfying the following requirements org.eclipse.ui [3.4.2.M20090204-0800].

If try to install by the zip file, put the files in droping folder, dont works...

Fred said...

And now I reinstall Eclipse and got the following error:

Cannot complete the request. See the details.
Unsatisfied dependency: [org.python.pydev 1.5.3.1260390783] requiredCapability: osgi.bundle/org.eclipse.compare.core/0.0.0
Unsatisfied dependency: [org.python.pydev 1.5.3.1260390783] requiredCapability: osgi.bundle/org.eclipse.compare.core/0.0.0
Unsatisfied dependency: [com.python.pydev 1.5.2.1260362205] requiredCapability: osgi.bundle/org.python.pydev.debug/0.0.0
Unsatisfied dependency: [com.python.pydev 1.5.2.1260362205] requiredCapability: osgi.bundle/org.python.pydev/1.5.2.1260362205
Unsatisfied dependency: [org.python.pydev.templates 1.5.3.1260390783] requiredCapability: osgi.bundle/org.python.pydev/0.0.0

Can anybody help me?

Fred said...

I'm using the MacOS 10.5 Leopard. Before I reinstall the Eclipse, all works fine... but after reinstall, I cant install PyDev... I'm freak out...!!!

Fabio Zadrozny said...

Anyone needing to use Eclipse 3.4 or earlier, please stick to version 1.5.1 for now.

Fred said...

How to intall version 1.5.1? Via update I can get only 1.5.3...

Fabio Zadrozny said...

You should be able to get it if in the install wizard you uncheck the option to show only the latest version.

Fabio Zadrozny said...

You should be able to get it if in the install wizard you uncheck the option to show only the latest version.

Fred said...

thanks!!! everything works fine now!!!!

Fabio Zadrozny said...

Ok, Just fixed it. The latest version 1.5.3 should be working for Eclipse 3.4 now.

Kevin Bowling said...

Pydev is excellent, thank you for your work!

Steven said...

This is great. They syntax highlighting in the compare editor is a wonderful feature. Thanks for all your work.

Anonymous said...

Hello I just found a rather large and annoying bug. I wanted to report it on sourceforge, but I couldn't login.

If you use code folding to collapse some text, and then proceed to delete something after the collapsed block, the position of your cursor isn't updated, and it deletes the text that was there before you folded it away!

So if you fold the first function here, and delete the "f" in "def two", you will end up deleting the "p" in "pass".

def one():
pass

def two():
return

Fabio Zadrozny said...

Please try to report that as a bug -- create a new login if needed (this is not the place for reporting bugs).

Also, please add info on the versions of eclipse/pydev you're using.

Cheers,

Fabio

Anonymous said...

Fabio: I'm using Eclipse 3.5.1 and PyDev 1.5.3.1260479439.

I tried to login to sourceforge but it kept on saying there was an error even when I made a new login. I am too frustrated to try again.

I know you are probably very busy and dislike seeing a bug report on here instead of on sourceforge, but sourceforge simply isn't letting me login.