Tuesday, January 13, 2009

Pydev 1.4.2

Ok, the Pydev 1.4.2 is just out.

The major feature this release has been long awaited: each project can now have a different configured interpreter.

As a result of that change, some internal structures will have to be recreated. So, right after upgrading it's expected that Pydev will do some processing to make that right, and now, it has to gather the information for all the interpreters, and not only for the current one, so, be a bit patient while it does that (it'll do that just once).

Also, many fixes were made available, so, upgrading is really reccommended.

4 comments:

Anonymous said...

Seems that site-packages import/code completion is broken in this release.
Python 2.5.4 under WinXP SP3, Eclipse 3.4. Everything installed with easy_install works as expected; Pydev code completion doesn't pick the packages though.

Fabio Zadrozny said...

Please report that as a bug with a specific code example on what you expected it to get which it is not finding.

Cristian Salamea said...

works with eclipse 3.4?, i have installed 1.4.2 but doesnt works autocomplete code if you suggest me anything, thx

Fabio Zadrozny said...

Yes, it should work. Please add questions on why it's not working in the forum (with your specific case): http://sourceforge.net/forum/forum.php?forum_id=293649

Cheers,

Fabio