Wednesday, July 18, 2007

Pydev 1.3.7 and 1.3.8

Well, I didn't blog about 1.3.7 before -- and now 1.3.8 is already out ;-)

Both releases are pretty much focused on bug-fixing, solving some issues regarding the integration with Eclipse 3.3 and java 1.6.

Other noteworthy things are:

The code-completion engine uses some more heuristics for type inference (together with some other approaches -- which are pretty much the same thing). So, the following is now considered:
- Python: assert isinstance(xxx, Class)
- PyProtocols: adapt(obj, Class)
- Zope: assert Interface.implementedBy(obj)

And the Pydev Extensions Code-Analysis now detects mixing of tabs/spaces.

1 comment:

ricnar said...

i install pydev 1.38 in eclipse 3.3 with problem of the support of mylyn, there is a solution for this bug or with the mylyn disabled work well.