Wednesday, June 27, 2007

Pydev and JDT (SDK not required anymore)

I forgot to mention about it... Pydev 1.3.5 does not require JDT to work anymore (it's set as an optional dependency, only needed for jython development), so, users that are interested only in python can download the Eclipse Platform Runtime Binary instead of the whole SDK.

There's only one minor problem with that: the platform does not include the Error Log (which is usually useful when something goes wrong for bug reports) -- so, if you're using only the runtime and not the whole SDK, you need to look through the .metadata/.log file for those errors.

Another option is getting only the plugin that adds the error log view: org.eclipse.pde.runtime_XXX.jar -- it's pretty small (147kb here), but it needs to be gotten in the SDK.

1 comment:

Marcelo said...

IMHO, This is a very good improvement!
You (or anybody) could pack the Eclipse Platform Runtime Binary + PyDev and offer it as another "Eclipse Distro", or Python IDE. :-D

Regards, and thanks for your work
Marcelo
http://marcelosoft.blogspot.com