Tuesday, March 27, 2007

Pydev 1.3.1 released (and Mylar integration)

Bug-fixes for everyone ;-)

I'm finally getting into how the package explorer should be used (after lots and lots of pitfalls)... the flat view is still not there, but all the other things should be already working -- I'm using it everyday, and have not seen a glitch in it in quite some, time, so, I think it can already be considered stable.

There's also a feature created for the mylar integration (you still have to add *.pyc files to the resources that mylar should ignore -- I've already submitted them a patch so that this is done automatically when using it), but aside from that it should be working well (it was actually pretty easy to integrate -- but it's still only integrated in the module level and not in the class/method level -- which I actually don't find myself using very much when using java anyways, so, I don't consider that a big hindrance).

So, enjoy...

9 comments:

nirvdrum said...

Great news on the mylar integration -- I look forward to checking it out. Please, however, don't go down the path of "I don't use it, so it's not useful." I know a lot of people that use the method-level context quite heavily. Hopefully it can get added in a future release.

nirvdrum said...

Great news on the mylar integration -- I look forward to checking it out. Please, however, don't go down the path of "I don't use it, so it's not useful." I know a lot of people that use the method-level context quite heavily. Hopefully it can get added in a future release.

Fabio Zadrozny said...

I agree that it should be integrated -- my choice was more like: get an early integration that works, and improve it based on user requests ;-)

Anonymous said...

mylar integration rocks!

Anonymous said...

Your web site, http://www.fabioz.com/pydev, is down.

Will it be back up any time soon?

How else can we get pydev extensions? Thanks!

Fabio Zadrozny said...

Thanks for the heads up... I still don't know what caused it, but I'm trying to track it down...

So, it should be back up not long from now...

Cheers,

Fabio

Anonymous said...

I get this error when using the eclipse update:

"Pydev Mylar Integration (0.2.0) requires plug-in "org.eclipse.mylar (2.0.0.v20070403-1300)", or later version."

Fabio Zadrozny said...

What's the mylar version (Pydev still does not support Mylyn -- but that support should be added pretty soon).

Cheers,

Fabio

Throgmorton said...

I got this error too just now when I used the update link from pydev.sourceforge - http://pydev.sourceforge.net/updates/

but the fabioz link - http://www.fabioz.com/pydev/updates - worked fine.